安装wordpress时出现Cannot modify header information – headers already sent by错误信息

最近我在我的godaddy空间上安装wordpress(3.01cn版本)时,出现

Warning: Cannot modify header information – headers already sent by (output started at /home/content/***/html/***/wp-config.php:1) in /home/content/***/html/***/wp-includes/pluggable.php on line 890

百思不得其解,上万能的网搜索了半天,发现有如下解决办法:

1.php.ini配置问题,解决办法:打开 php.ini 然后把 output_buffering 设为 on ,重启appache即可。

2.使用windows记事本编辑的wp-config文件造成(UTF8编码和BOM冲突),解决办法:使用Notepad++、UltraEdit、EditPlus等编辑器编辑文件,一般的主机管理系统自带的编辑功能也不错。

3.还有wpchina.org上的一篇文章,里面讲到如果PHP文件里在 “<?php” 之前和在 “?>” 之后存在别得字符可能会引起异常。

于是,

第1,我修改了php.ini文件,错误依旧;

第2,我用EditPlus用编辑器打开wp-config文件,再保存,问题依旧;

第3,用编辑器打开wp-config文件,竟然没有发现“?>

现在真不知道该怎么解决这个问题了,望高人指点!

哈哈,最后我终于搞定了,果然是编码问题,我用EditPlus用编辑器打开wp-config文件,然后直接另存为,编码选择为ANSI/ASCII,就可以了,改好后传到服务器上,刷新,OK,WP可以正常安装了!